Your server is running PHP version 4.4.9 but WordPress 4.1.4 requires at least 5.2.4.